Tuesday, April 23, 2013

Error A Previous version of Nightwatchman has been detected on your machine. You must remove Nightwatchman before continuing with the install

 

"Error A Previous version of Nightwatchman has been detected on your machine.  You must remove Nightwatchman before continuing with the install"


 


The uninstaller via command line or Programs and Features would result in the above error message.

It was discovered that the MST file previously used to configure the MSI had been copied from from an earlier version 5, and had included references to the previous product ID.

By deleting the Transforms record the uninstallation was able to complete.


[HKEY_CLASSES_ROOT\Installer\Products\E5A3EA51A6783284B9EDA9396E6A772C]

"ProductName"="1E Agent"

"PackageCode"="7D32A2D932D351543AA64E478D052BFD"

"Version"=dword:06000064

"Transforms"=C:\WINDOWS\Installer\{15AE3A5E-876A-4823-9BDE-9A93E6A677C2}\Custom1EAgent.mst

No comments:

Post a Comment